electroZ microsystems

Doc/LPKF

Version 1.04

Sommaire

Concepte

Le travail pour la réalisation de PCB par fraisage ou celui pour la réalisation de pièces en CNC de manière générale et divisé en trois phases:

CAO (CAD) CAM CNC
Conception assitée par ordinateur (Computer aided design) Computer aided manufacuring Computer numerical control

Dessin du PCD, routage des pistes, placement des composants. Dessin de pièces mécaniques

Routage automatique des passages de fraises Pilotage de la machine
Sprint-Layout CircuitCAM BoardMaster
Protel
Eagle
Rhino
SolidWorks
Inventor
...
MasterCAM
AlphaCam ...
emc2
CnFraise
MACH3
NINOS ...

Des operations d'exportation, importation nous permettent de passer d'une phase à l'autre.

Sprint-Layout
CircuitCAM BoardMaster
dessin
export import
routage export impor
gravage, persage
top (C1) ProjectTop.gbr top
rubout top
InsulateTop_small
(Universal Cutter 0.2)
7. Milling Top
InsulateTop_Std
(EndMill 1.0 mm )
InsulateTop_Big
(EndMill 1.0 mm)
InsulateTop_Bigger
(EndMill 2.0 mm)
bottom (C2) ProjectBot.gbr bottom
rubout bottom
InsulateBottom_small
(Universal Cutter 0.2)
5. Milling Bottom
(coté racle)
InsulateBottom_Std
(EndMill 1.0 mm)
InsulateBottom_Big
(EndMill 1.0 mm)
InsulateBottom_Bigger
(EndMill 2.0 mm)
mecanical (S1) ProjectMec.gbr border outline CuttingOutside
(Contour router 2.0mm)
8. CuttingInside
CuttingOut (S1) ProjectCut.gbr CuttingOutside 9.CuttingOutside
Hole Project.drl
drillPlated
1. MarkingDrills
(coté racle)
2. DrillingPlated
(coté racle)

CAO

Dessin des contours

Dessiner les coutours de la carte sur la couche S2 avec une piste de 2mm, les points d'attaches sont séparés de 2.54.
Les dimensions de la carte correspondent aux contours intérieurs de ce tracé.

Choix des forets

Choisir dans la liste suivante: 0.4 / 0.5 / 0.6 / 0.7 / 0.8 / 0.85 / 0.8 / 1 / 1.1 / 1.2 / 1.3 / 1.4 / 1.5 / 1.6 / 1.7 / 1.8 / 1.9 / 2 / 2.1 / 2.2 / 2.3 / 2.4 / 3

Pour les trous plus grands que 3mm boardMaster utilisera automatiquement une fraise pour réaliser le trou.

Si on choisit un diamètre de trous autre que ceux proposés ci-dessus boardMaster prendra le foret le plus proche dans la liste ci-dessus.

Il est préférable de limiter un maximum le nombre de foret pour éviter d'avoir à faire des changements d'outils en cours de production.

Dessin des pistes

C2 : Bottom , C1 : Top

Les règles de layout sont (typiquement): distances entre les pistes min 0.254mm, largeur des pistes min 0.254mm.

Exportation Gerber

C2 -> ProjectBottom.gbr (pas de miroir)
S2 -> ProjectCutting.gbr (pas de miroir)
C1 -> ProjectTop.gbr (pas de miroir)

Exportation Excellon

utiliser [inch 2.4]

Perçage de la face 1. Le perçage vu depuis TOP (pas de miroir)


CAM importation

L'opération d'importation consiste à récupérer les différents fichiers gerber et excellon et leur réatribuer une fonction (les replacer sur la bonne couche)

Importation des contours (pré routé) de la carte Image:import.jpg

  • Fichier->Import
    • Fichier: ProjectCuttin.gbr
    • Type: GerberX
    • Couche:CuttingOutside
  • Sélectionner la couche

Image:LayerTools.jpg

  • Définir la classe d'outils pour cette couche
    • LpkfCuttingTools
  • Définire l'outil
    • Coutour Routeur 2.0mm

(L'autre méthode est d'utilser un simple tracé de coutour de la carte (mecanical) et d'utiliser l'outil
Editer->Routage de contour. ) Plus de détails dans la section suivante "CAM routage"

Importation Bottom Image:import.jpg

  • Fichier->Import
    • Fichier: ProjectBottom.gbr
    • Type: GerberX
    • Couche:BottomLayer

Importation Top Image:import.jpg

  • Fichier->Import
    • Fichier: ProjectTop.gbr
    • Type: GerberX
    • Couche:TopLayer

Importation des trous Image:import.jpg

  • Fichier->Import
    • Fichier: Project.drl
    • Type de fichier:NC-Drill
    • Type: NCDrillDefault
    • Couche:DrillPlated
    • Unité:Pouce
    • Chiffres:2.4 (la même valeur que durant la phase d'exportation avec Sprint Layout)

Quelques trucs

  1. Pour sélectionner une piste cliquer proche des angles

Lors d'une opération de sélection il est important de cliquer sur les points qui forment les objets et non sur les lignes qui représentent les objets.
Si on clique sur les extrémités ou sur les angles la sélection se fait correctement.
Sur les deux exemples ci-dessous la première sélection fonctionne, la deuxième non.




  1. Comprendre les outils de sélection

    Image:selection.jpg

    1. Image:plus.jpg Ajouter des éléments à la sélection

    2. Image:moin.jpg Retirer des éléments de la sélection

    3. Image:egal.jpg Sélectionner uniquement un élément

    4. Image:couche.jpg Appliquer l'action + - ou = a l'ensemble de la couche du dernier objet sélectionné

    5. Lorsqu'une couche est sélectionnée on peut voir le nom de cette couche, le genre d'outils et l'outil utilisé au niveau CNC. Image:LayerTools.jpg

CAM routage

L'opération de routage consiste a utiliser les couches des pistes, des trous, des contours de cartes pour créer des nouvelles couches représentant les passages d'outils utiliés par le contrôleur CNC.

Définition de la couche de détourage

Vérifier que tous les contours de découpe de la carte aient comme définition d'outil un contour routeur 2.0mm

Si on n'a pas défini le tracé de l'outil de découpe avec Sprint-Layout mais uniquement les dimentions de la carte avec un simple cadre on peut router automatiquement le passage de la fraise de découpe avec les fonctions suivantes.

Editer->Routage de contour...

Cette méthode est en fait plus rapide si on a pas besoin de définir avec précision les points d'attaches.

Image:contour3.jpg

Rub out (effacer)

Définir les zones où le cuivre inutile doit être laissé ou effacé. Par défaut le cuivre n'est pas enlevé à part le détourage des pistes, à l'intérieur des zones de rubout le cuivre est enlevé.

  1. Désélectionné tout avec Image:moin.jpg puis Image:egal.jpg
  2. Tracer des cadres ou autres formes dans les couches RuboutTop ou RuboutBottom ou RuboutAll. Avec la fonction Insérer->Rectangle puis choisir la couche RuboutTop ou RuboutBottom ou RuboutAll et tracer le cadre.

Routage Bottom

C'est là toute l'utilité de ce programme CircuitCAM: le calculs des passages d'outils.

Utiliser la fonction Editer->Isoler ...

Voici un exemple standard de paramétrage de l'outil de routage des passages d'outils.

Image:isolationMain.jpg

Travail: En sélectionnant Haut ou bas on charge les paramètres près enregistrés. On peut enregistrer de nouvelles configurations afin de gagner du temps au prochain job.

Outil: Permet de définir les types d'outils à utiliser pour le détourage fin, moyen ou grossier.

Largeur Base: Définit la taille à enlever autour des pistes.

Traçage de maquette: Définit le sens prioritaire du passage des fraises.

Image:isolationAdvanced.jpg

Base: La couche que l'on doit isoler

Effacer 1 et 2: Les zones ou l'on doit effacer tout le cuivre

Destination: La base du nom des couches de destination

Les couches

  • InsulateBottom__Small
  • InsulateBottom__Std
  • InsulateBottom__Big
  • InsulateBottom__Bigger

seront créées en ajoutant au nom de Destination les suffix __Small, __Std, __Big, _Bigger.

Puis enfin lancer l'opération de routage avec le bouton Exécuter.

Image:Executer.jpg

Cette opération génère les couches et donne un résultat comparable à l'illustration ci-dessous:

Image:routage2.jpg

  1. Zone de cuivre
  2. Couche CuttingOutside, passage de l'outil contour routeur
  3. Point d'atache
  4. Couche InsulatedBottom_Std et __Big, passage de l'outil End_Milling 1mm
  5. Couche InsulatedBottom_Small, passage de l'outil UniversalCutter
  6. Trous de > 3mm réalisé avec un contour routeur
  7. Trous de <= 3mm réalisé avec un foret
  8. Contour de la zone de ruboutBottom
  9. Zone de rubout, Passage de l'outil End_Milling 2mm

Routage Top

Idem a Bottom

Exportation

Sauvegarder le travail:Fichier->Enregistrer (Projet.cam)

Démarrer BoardMaster (voir chapitre suivant:CNC) puis exporter les couches et informations d'outillage avec le bouton Image:exporter.jpg Le fichier d'exportation est Project.lmd


CNC

L'opération sur la CNC consiste à régler la machine, importer les fichiers d'usinage, mettre les bons outils en place et exécuter les tâches de perçages, détourage des pistes et découpage des contours.

Philosophie

Le système travaille avec des circuits simples ou doubles faces. Lorsqu'il travaille uniquement en simple face il considère la face à usiner comme bottom. On commence donc par bottom dans ce cas. Lorsqu'on travaille en double face on suit la même logique et on commence par bottom (perçage, détourage). Ensuite on tourne la plaque et on fait le détourage et le découpage.

Mise en marche de la machine

Démarrage de boardMaster

A la fenêtre "Tool Status" : si tous les outils sont dans le magasin d'outils il faut uniquement appuyer sur [OK] sinon il faut indiquer la position libre de l'outil. Les emplacements d'outils son numérotés de gauche à droite et de 1 à 10.

Il faut être très prudent à ce moment car si l'on se trompe la machine va déposer un outil dans un emplacement déja occupé et l'on risque ainsi d'endommager la machine.

[ARRET D'URGENCE] : On peut interrompre instantanément les opérations sur la machine en ouvrant le capot.

Fixation de la matière , réglage et configuration de la machine

i. Vérification que les outils en place correspondent à la liste des outils

  Utiliser le bouton Image:tools.jpg pour visualiser la liste des outils et la modifier.

ii Inserer un board.

Réglage des dimensions (X,Y) du circuit

  Configuration->Matériel->dimension...

Pour l'épaisseur de la plaque il faut la mesurer et noter précisément la valeur réelle.


iii. Réglage de la hauteur Z

- Charger un outil Universal cutter 0.2 dans la broche. [1]

- Positionner la broche sur un endroit libre du circuit. [2] puis click sur une zone libre.

- Allumer le moteur. [3]

- Descendre la broche. [4]

- Tracer une petite ligne (10mm). [5]

- Remonter la broche. [4]

- Eteindre le moteur. [3]

- Eteindre le vacuum. [VAC]

- Deplacer la broche en position pause.[P]

Cette ligne devrait avoir une épaisseur de 0.2 mm au besoin corriger avec la mollette sur la broche.

  Sens horaire: la broche descend -> L'épaisseur de la trace augmente de ~0.01mm par click.
  Sens anti-horaire: la broche monte -> L'épaisseur de la trace diminue de ~0.01mm par click.

iv. Réglage de la caméra

v. Définition des phases

  Configuration->Phases...
  • Milling Bottom, drilling -> côté racle (reversed side)

Pour un circuit double faces:

  * Milling Top, cutting outside -> pas côté racle

Pour un circuit simple face:

  * Cutting outside -> côté racle

Importation des jobs

Si bordMaster est démarré quand on fait l'exportation avec CircuitCAM le job est automatiquement importé dans boardMaster. On peut aussi importer manuellement les fichiers .lmd avec Fichier->Import.

On peut voir la liste des jobs actuellement ouverts avec la fenêtre Edit->Placement...



  1. Origine représente la position par rapport 0
  2. Rotation permet de faire une rotation de 90° par exemple
  3. Count permet de multiplier les jobs en grille.
  4. Déplacement permet de définir l'espace entre les origines de chaque pièce de la grille. Par défaut l'espace est calculé de façon à faire un seul passage de découpage entre deux cartes.
  5. Add... permet de dupliquer un job

On peut aussi déplacer un job en utilisant le bouton image:move.jpg


Image:workingSpace.jpg

Sur cette image on voit une carte positionnée avec l'origine (0,0) et sans rotation et une carte positionnée a (361,88), en vue bottom ça donne (361,-88) elle est répétée 4 fois en Y (Y de la carte avant la rotation).

Placement des bons outils

Il est préférable de remplir le magasin d'outils avec les bons outils avant le début du travail.

Dans tous les cas il faut vérifier que les outils dans le magasin correspondent à la liste des outils de boardMaster

Utiliser le bouton Image:tools.jpg pour visualiser la liste des outils et la modifier.

Image:toolBox.jpg

Pour les experts: On peut aussi changer l'attribution des outils.

Pour voir la liste des outils utilisés par un job, on ouvre la fenêtre Edit->Tool assignement ...

Image:EditToolAssignement.jpg

Cette fenêtre nous permet aussi de redéfinir l'utilisation des outils.

Pointage des trous

  1. Sélectionner l'opération "1. MarkinkDrill"
  2. Choisir le mode sélection avec le bouton Image:select.jpg et sélectionner les parties à usiner
  3. Ajouter la sélection avec le bouton Image:plusCNC.jpg
  4. Démarrer le job avec le bouton Image:RUN.jpg

Perçage

  1. Sélectionner l'opération "2. DrillPlated"
  2. Choisir le mode sélection avec le bouton Image:select.jpg et sélectionner les parties à usiner
  3. Ajouter la sélection avec le bouton Image:plusCNC.jpg
  4. Démarrer le job avec le bouton Image:RUN.jpg

Détourage bottom

  1. Sélectionner l'opération "5. MillingBottom"
  2. Choisir le mode sélection avec le bouton Image:select.jpg et sélectionner les parties àusiner
  3. Ajouter la sélection avec le bouton Image:plusCNC.jpg
  4. Démarrer le job avec le bouton Image:RUN.jpg

Si on remarque que la fraise est usée (la découpe n'est pas nette) il est possible de stopper le processus avec la bouton [STOP], déposer la fraise, la remplacer par une neuve et redémarrer le processus. Le job va continuer quasi exactement ou il s'était arrêté. Il se peut toutefois que lors du STOP/START il oublie quelques mm de détourage et fasse donc éventuellement un court-circuit sur la carte. Donc c'est à vérifier...



Note: Pour les grandes plaques il est possible de mettre deux fraises de 1mm par exemple. Quand la fraise a fait son kilométrage maximum nominal boardMaster devrait automatiquement changer d'outil. (...A vérifier...)

Détourage top

  1. Mettre la machine en position pause Image:pause.jpg , ouvrir et RETOURNER LE PCB DE BAS EN HAUT
  2. Sélectionner l'opération "5. MillingBottom"
  3. Choisir le mode sélection avec le bouton Image:select.jpg et sélectionner les parties àusiner
  4. Ajouter la sélection avec le bouton Image:plusCNC.jpg
  5. Démarrer le job avec le bouton Image:RUN.jpg

Découpe des coutours

  1. Sélectionner l'opération "9. CuttingOutsige"
  2. Choisir le mode sélection avec le bouton Image:select.jpg et sélectionner les parties à usiner
  3. Ajouter la sélection avec le bouton Image:plusCNC.jpg
  4. Démarrer le job avec le bouton Image:RUN.jpg

Sortir la plaque

  1. Mettre la machine en position pause Image:pause.jpg , ouvrir et sortir la plaque
  2. refermer le capot


Rangement de la machine

  1. Ranger l'outil dans le magadin d'outils en sélectionnant dans le choix des outils "Quick load"

    Image:QuickLoad.jpg
  2. Ranger la tête en position repos avec le bouton Image:repo.jpg
  3. Nettoyer la machine
  4. Arrêter le programme boardMaster
  5. Arrêter la machine

Annexes

Allignement des couches avec la caméra

Mise en marche de la caméra

Configuration -> Paraètre -> Armer -> check caméra -> Sauver -> OK

Calibration de la position de la caméra

Charger un foret et faire un trou

Positioner la camera en dessus du trous avec la commande

  Deplacer ver -> Caméra>>Tête 

Si le trous n'est pas parfaitement centré sur la mire corriger avec avec les 4 bouttons de possionement par pas de 0.1 mm. Mémoriser le nombre de mm déplacer pour que la mire soit parfaitement centrée. Bouton du haut on Y est incrémenter. Boutton de droite Y est incrémenté.

Les valeurs sont a ajouter aux valeur dans :

  Configuration -> Tete -> Camera X,Y

Redéplacer la caméra avec la fonction

  Deplacer ver -> Tête>>Caméra

On recommence l'opération jusqu'a ce que la mire soit parfaitement centrée.

image:camera_ok.png

Calibration de la position de la tête

Zoumer sur un trou (du fichier CAM)et positionner la tete exactement sur ce trou virtuel.

Deplacer en position camera pour voire le trou réel cette fois.

  Deplacer ver -> Caméra>>Tête 

Ajuster la mire en notant les déplacements X et Y cette foit avec la flèche à droite on a X qui est décrémenté et avec le boutton UP on a Y qui est décrémenté (contrairement au positionnement de la caméra)

Reporter ces déplacement dans

  Configuration -> Tete -> Tete X,Y


puis

   Deplacer ver -> Tête>>Caméra

Puis reverifiez!

KiCAD -> Gerber

Utiliser simplement les options par defaut.


Protel 99 -> Gerber

Il faut choisir les mêmes options pour les Gerber et pour les trous

Le fichier de perçage à utiliser est projetName.txt (*)

image:prote2gerber.jpg image:protel2NCDrill.jpg

(*)Le fichier de perçage est du format suivant:

  M72
  M48
  T1F00S00C0.0236
  T2F00S00C0.0315
  T3F00S00C0.0320
  T4F00S00C0.0394
  T5F00S00C0.0433
  T6F00S00C0.0551
  T7F00S00C0.1850
  %
  T01
  X7283Y9213
  Y9921
  Y10669
  Y11378
Voilà !